Skip to main content
VulnerabilityPublished

CVE-2026-114607: better-auth · Improper Authentication

Affects better-authSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.7.7 as a priority.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-23.

Patch
Available – fixed in 1.7.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade better-auth to 1.7.7.

Affected software

ProductAffectedFixed in
better-authbetter-authAffected
  • >=1.4.0-beta.18 <1.7.7
Fixed in
  • 1.7.7

AI-suggested

Upgrade better-auth to version 1.7.7 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.

Description

CVE-2026-114607 is a critical improper authentication vulnerability in the better-auth TypeScript library versions from 1.4.0-beta.18 up to but not including 1.7.7. The flaw arises when specific configuration settings involving Magic Link tokens and OAuth state identifiers cause these tokens to be treated equivalently. This allows an attacker to bypass authentication by redeeming OAuth sign-in state values as Magic Link tokens without mailbox control or completing OAuth callbacks, potentially gaining unauthorized user sessions or creating accounts marked as email verified. The issue is fixed in version 1.7.7.

References

Community reviews

Loading reviews…