CVE-2026-114617: authlib · Authentication Bypass by Capture-replay
Affects authlibSource CVE Database V5
Not known to be exploited · CVSS 4.2 Medium : upgrade to 1.9.0 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-10-23.
- Patch
- Available – fixed in 1.9.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade authlib to 1.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| authlibauthlib | Affected
| Fixed in
|
AI-suggested
Upgrade Authlib to version 1.9.0 or later, where this vulnerability is fixed. No other mitigation is indicated or required as the fix addresses the root cause by properly handling the nonce_supported claim.
Description
Authlib versions prior to 1.9.0 contain an authentication bypass vulnerability in the OpenIDMixin.parse_id_token() method. This flaw allows an attacker who captures a valid signed ID token to replay it into an attacker-controlled session by exploiting how the nonce_supported claim is handled. The issue affects implicit and hybrid OpenID Connect flows or applications accepting externally supplied ID tokens. The vulnerability does not affect the plain authorization code flow and requires the token to pass signature, issuer, and audience validation. The flaw is fixed in Authlib version 1.9.0.
References
- github.com/authlib/authlib/security/advisories/GHSA-c5mf-xmp2-59rc (opens in a new tab)
- github.com/authlib/authlib/pull/949 (opens in a new tab)
- github.com/authlib/authlib/commit/6563f6f7a8c2f71d2f85ee7511d72a4fbae3acc0 (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.9.0 (opens in a new tab)