CVE-2026-114618: authlib · Improper Authentication
Affects authlibSource CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 1.9.0 when convenient.
Data as of 26 Oct 2026, 09:29 UTC
- Patch
- Available – fixed in 1.9.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade authlib to 1.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| authlibauthlib | Affected
| Fixed in
|
Description
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.9.0, the default RFC 7523 JWTBearerGrant.get_audiences() returns an empty list, causing JWTBearerGrant.verify_claims() to require only that an aud claim exists without matching the current authorization server. An attacker holding a legitimate assertion for another service can present it to a server that shares the signing key and uses the default grant, obtaining an access token across a trust boundary. Implementations that override get_audiences() with the server's valid audience identifiers are not affected. This issue is fixed in version 1.9.0.
References
- github.com/authlib/authlib/security/advisories/GHSA-fch4-3c6x-j4gc (opens in a new tab)
- github.com/authlib/authlib/pull/945 (opens in a new tab)
- github.com/authlib/authlib/commit/e3bd41cb29dcfee434453b135ffb487884baeedf (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.9.0 (opens in a new tab)