CVE-2026-116672: authlib · Insecure Direct Object Reference
Affects authlibSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 1.9.1 soon.
Data as of 27 Oct 2026, 17:24 UTC
- Patch
- Available – fixed in 1.9.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade authlib to 1.9.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| authlibauthlib | Affected
| Fixed in
|
AI-suggested
Upgrade Authlib to version 1.9.1 or later, where this authorization bypass vulnerability is fixed. No other mitigations are indicated by the vendor advisory.
Description
Authlib versions from 0.15 up to but not including 1.9.1 contain an authorization bypass vulnerability in the ClientConfigurationEndpoint implementations. These implementations improperly verify client permissions by only checking if the target client is editable, without confirming that the request credential belongs to that client. This flaw allows any client with a valid registration access token to read, modify, or delete other clients' registrations. Modifying redirect_uris could lead to authorization code or token interception, and deleting registrations can cause denial of service for affected clients. The vulnerability is fixed in version 1.9.1.