Skip to main content
VulnerabilityPublished

CVE-2026-115216: Eclipse ioFog · Improper Certificate Validation

Affects Eclipse ioFogSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.9.2 as a priority.

Data as of 27 Oct 2026, 12:12 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.9.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:L/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Eclipse ioFog and eclipse-iofog/iofog-operator to 3.9.2.

Affected software

ProductAffectedFixed in
Eclipse FoundationEclipse ioFogAffected
  • >=3.8.0 <3.9.2
Fixed in
  • 3.9.2
GitHubeclipse-iofog/iofog-operatorpkg:github/eclipse-iofog/iofog-operatorOther threatsAffected
  • >=3.8.0 <3.9.2
Fixed in
  • 3.9.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Eclipse ioFog Operator to version 3.9.2 or later, where TLS certificate verification is properly enforced. No other mitigations are indicated by the vendor advisory. Applying this official fix fully resolves the vulnerability.

Description

Eclipse ioFog Operator versions 3.8.0 up to but not including 3.9.2 disable TLS certificate verification when communicating with the Controller API and logging into an external OIDC issuer. This improper certificate validation allows an on-path attacker to present any certificate, potentially capturing sensitive credentials such as the OAuth client secret or the Controller bootstrap admin password. The vulnerability was fixed in version 3.9.2.

References

Community reviews

Loading reviews…