Skip to main content
VulnerabilityPublished

CVE-2026-115362: openbao · Insufficient Session Expiration

Affects openbaoSource CVE Database V5

0

Not known to be exploited · CVSS 2.1 Low : upgrade to 2.7.1 or 2.6.4 when convenient.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.7.1, 2.6.4
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade openbao to 2.7.1 or 2.6.4.

Affected software

ProductAffectedFixed in
openbaoopenbaoAffected
  • >=2.7.0 <2.7.1
Fixed in
  • 2.7.1
openbaoopenbaoAffected
  • <2.6.4
Fixed in
  • 2.6.4
Goopenbaopkg:golang/openbaoOther threatsAffected
  • <2.6.4
  • >=2.7.0 <2.7.1
Fixed in
  • 2.6.4
  • 2.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenBao to version 2.6.4 or later, or 2.7.1 or later, where the issue is fixed. These versions properly check Secret ID expiration at the time of use, preventing expired Secret IDs from being accepted. No other mitigation is indicated or necessary as the fix addresses the root cause.

Description

OpenBao versions before 2.6.4 and 2.7.x before 2.7.1 have a vulnerability in the AppRole authentication method where expired Secret IDs are not checked at the time of use. This allows expired Secret IDs to remain valid until a periodic cleanup process removes them, potentially enabling attackers holding such expired IDs to log in and access the system beyond the intended time-to-live (TTL).

References

Community reviews

Loading reviews…