Skip to main content
VulnerabilityPublished

CVE-2026-115457: baserproject basercms · Cross-site Scripting

Affects baserproject basercmsSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 5.4.2 or 5.3.2 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.2, 5.3.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade basercms and baserproject/basercms to 5.4.2 or 5.3.2.

Affected software

ProductAffectedFixed in
baserprojectbasercmsAffected
  • >=5.4.0 <5.4.2
Fixed in
  • 5.4.2
baserprojectbasercmsAffected
  • >=5.0.0 <5.3.2
Fixed in
  • 5.3.2
GitHubbaserproject/basercmspkg:github/baserproject/basercmsOther threatsAffected
  • >=5.0.0 <5.3.2
  • >=5.4.0 <5.4.2
Fixed in
  • 5.3.2
  • 5.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been officially fixed in baserCMS versions 5.3.2 and 5.4.2. Users should upgrade to these or later versions to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

baserCMS versions 5.0.0 before 5.3.2 and 5.4.0 before 5.4.2 contain a stored cross-site scripting (XSS) vulnerability. This occurs because global shortcode expansion processes the entire rendered page, including HTML-escaped blog comments from unauthenticated users, allowing malicious scripts to execute in the context of site visitors or administrators. The vulnerability has been patched in versions 5.3.2 and 5.4.2.

References

Community reviews

Loading reviews…