Skip to main content
VulnerabilityPublished

CVE-2026-115914: vllm · Reachable Assertion

Affects vllmSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.32.0 when convenient.

Data as of 26 Oct 2026, 17:42 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.32.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade vllm to 0.32.0.

Affected software

ProductAffectedFixed in
vllm-projectvllmAffected
  • >=0.11.1 <0.32.0
Fixed in
  • 0.32.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to vLLM version 0.32.0 or later, where this assertion failure vulnerability is fixed. No other mitigation is indicated or required.

Description

vLLM versions from 0.11.1 up to but not including 0.32.0 contain a reachable assertion vulnerability (CWE-617) in the image processing path for certain OCR models. A remote client with access to the OpenAI-compatible API can submit a specific image that causes a fatal assertion failure, resulting in a shutdown of the inference engine for all users. This denial-of-service condition is fixed in version 0.32.0.

References

Community reviews

Loading reviews…