CVE-2026-41523: vllm · Code Injection
Affects vllmSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 0.22.0 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.22.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade vllm to 0.22.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vllm-projectvllm | Affected
| Fixed in
|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade vLLM to version 0.22.0 or later, where this vulnerability is fixed. Since this is a code execution vulnerability triggered by running vLLM in Python optimized mode, avoid running vLLM with python -O or PYTHONOPTIMIZE=1 if upgrading is not immediately possible. Patch status is confirmed fixed in 0.22.0 as per the vendor advisory.
Description
vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.0, an assert-based security check in vLLM's activation function loading allows any unauthenticated attacker to achieve arbitrary code execution on the server by publishing a malicious HuggingFace model, when vLLM runs in Python optimized mode (python -O or PYTHONOPTIMIZE=1). This vulnerability is fixed in 0.22.0.
References
- github.com/vllm-project/vllm/security/advisories/GHSA-q8gq-377p-jq3r (opens in a new tab)
- github.com/vllm-project/vllm/commit/b3c7ffcab82c2439726f8cb213800f6f38c023d3 (opens in a new tab)
- huntr.com/bounties/dcb05b04-e625-41e7-adbc-bbae0cc2d64c (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-41523 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2491582 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41523.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36005 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36006 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:57380 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:57390 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:57389 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:57387 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:59138 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:59139 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:59151 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:59144 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:61627 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:61629 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:62336 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:62335 (opens in a new tab)