Skip to main content
VulnerabilityPublished Updated

CVE-2026-22807: vllm · Code Injection

Affects vllmSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 0.14.0 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.14.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade vllm and vllm-project/vllm to 0.14.0.

Affected software

ProductAffectedFixed in
vllm-projectvllmAffected
  • >=0.10.1 <0.14.0
Fixed in
  • 0.14.0
GitHubvllm-project/vllmpkg:github/vllm-project/vllmOther threatsAffected
  • >=0.10.1 <0.14.0
Fixed in
  • 0.14.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of vLLM (0.14.0) is available that addresses this vulnerability by properly gating the loading of dynamic modules with the trust_remote_code setting. Users should upgrade to vLLM version 0.14.0 or later. Consult the Red Hat advisories for specific patched package versions and updates. No additional mitigations are indicated by the vendor advisory.

Description

vLLM is an inference and serving engine for large language models (LLMs). Starting in version 0.10.1 and prior to version 0.14.0, vLLM loads Hugging Face `auto_map` dynamic modules during model resolution without gating on `trust_remote_code`, allowing attacker-controlled Python code in a model repo/path to execute at server startup. An attacker who can influence the model repo/path (local directory or remote Hugging Face repo) can achieve arbitrary code execution on the vLLM host during model load. This happens before any request handling and does not require API access. Version 0.14.0 fixes the issue.

References

Community reviews

Loading reviews…