CVE-2026-115915: vllm · Improper Input Validation
Affects vllmSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.1 High : upgrade to 0.32.0 soon.
Data as of 26 Oct 2026, 19:57 UTC
- Patch
- Available – fixed in 0.32.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade vllm to 0.32.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vllm-projectvllm | Affected
| Fixed in
|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade vLLM to version 0.32.0 or later, where this vulnerability is fixed. Ensure that Ghostscript and Pillow dependencies are updated to versions not affected by CVE-2024-29510 and CVE-2026-59203 respectively. Deployments without the vulnerable dependencies are not impacted by the related effects. No other specific mitigations are indicated.
Description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
References
- github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h (opens in a new tab)
- github.com/vllm-project/vllm/pull/60022 (opens in a new tab)
- github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd (opens in a new tab)
- github.com/vllm-project/vllm/releases/tag/v0.32.0 (opens in a new tab)