Skip to main content
VulnerabilityPublished

CVE-2026-116488: NXP mcuxsdk-middleware-usb · Heap-based Buffer Overflow

Affects NXP mcuxsdk-middleware-usbSource CVE Database V5

0

Not known to be exploited · CVSS 7.0 High : upgrade to 2.13.0 soon.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.13.0
CVSS:4.0/AV:P/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mcuxsdk-middleware-usb and nxp-mcuxpresso/mcuxsdk-middleware-usb to 2.13.0.

Affected software

ProductAffectedFixed in
NXPmcuxsdk-middleware-usbAffected
  • <2.13.0
Fixed in
  • 2.13.0
GitHubnxp-mcuxpresso/mcuxsdk-middleware-usbpkg:github/nxp-mcuxpresso/mcuxsdk-middleware-usbOther threatsAffected
  • <2.13.0
Fixed in
  • 2.13.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to mcuxsdk-middleware-usb version 2.13.0 or later, where this heap buffer overflow vulnerability is fixed. No other mitigation or workaround is indicated.

Description

NXP MCUXpresso SDK USB middleware versions before 2.13.0 contain a heap-based buffer overflow vulnerability in the host audio, video, and CDC class drivers. This flaw arises because the drivers trust device-supplied bNumEndpoints and bLength values, allowing a malicious USB device to supply crafted descriptors that overflow the fixed-size epList array. This can lead to heap memory corruption, potentially enabling code execution or denial of service.

References

Community reviews

Loading reviews…