Skip to main content
VulnerabilityPublished

CVE-2026-116576: sebhildebrandt systeminformation · OS Command Injection

Affects sebhildebrandt systeminformationSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to 5.33.16 soon.

Data as of 26 Oct 2026, 20:42 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.33.16
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade sebhildebrandt systeminformation to 5.33.16.

Affected software

ProductAffectedFixed in
sebhildebrandtsysteminformationAffected
  • <5.33.16
Fixed in
  • 5.33.16
npmsysteminformationpkg:npm/systeminformationOther threatsAffected
  • <5.33.16
Fixed in
  • 5.33.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to systeminformation version 5.33.16 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

CVE-2026-116576 is an OS command injection vulnerability in the systeminformation Node.js library prior to version 5.33.16. The issue arises from improper sanitization of service names used in PowerShell commands on Windows, allowing an attacker to inject arbitrary PowerShell expressions. Exploitation requires local or forwarded attacker-controlled input to the vulnerable services() or getDynamicData() functions. The vulnerability is fixed in version 5.33.16.

References

Community reviews

Loading reviews…