Skip to main content
VulnerabilityPublished

CVE-2026-116871: SemanticMediaWiki · Uncontrolled Recursion

Affects SemanticMediaWikiSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 7.3.1 soon.

Data as of 27 Oct 2026, 10:57 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.3.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade SemanticMediaWiki and semanticmediawiki/SemanticMediaWiki to 7.3.1.

Affected software

ProductAffectedFixed in
SemanticMediaWikiSemanticMediaWikiAffected
  • >=3.0.0 <7.3.1
Fixed in
  • 7.3.1
GitHubsemanticmediawiki/SemanticMediaWikipkg:github/semanticmediawiki/SemanticMediaWikiOther threatsAffected
  • >=3.0.0 <7.3.1
Fixed in
  • 7.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Semantic MediaWiki to version 7.3.1 or later, where this uncontrolled recursion vulnerability is fixed. No other mitigation or workaround is indicated in the advisory.

Description

Semantic MediaWiki versions 3.0.0 through 7.3.0 contain an uncontrolled recursion vulnerability in the LegacyParser::getSubqueryDescription() function. This flaw allows unauthenticated attackers to submit deeply nested query elements via the action=ask API, causing excessive CPU and memory consumption and tying up server request workers. The vulnerability is fixed in version 7.3.1.

References

Community reviews

Loading reviews…