CVE-2026-117537: redaxo core · Cross-site Scripting
Affects redaxo coreSource CVE Database V5
Not known to be exploited · CVSS 2.1 Low : upgrade to 5.21.0 when convenient.
Data as of 27 Oct 2026, 11:27 UTC
- Patch
- Available – fixed in 5.21.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade core and redaxo/core to 5.21.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| redaxocore | Affected
| Fixed in
|
GitHubredaxo/corepkg:github/redaxo/coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade REDAXO core to version 5.21.0 or later, where this vulnerability is fixed. No additional mitigation is required as the fix addresses the root cause.
Description
REDAXO core versions before 5.21.0 contain a reflected cross-site scripting (XSS) vulnerability. Authenticated attackers can exploit this flaw by injecting malicious scripts via the 'type' parameter in the metainfo_default_fields_create API. The vulnerability arises because rex_view::message() renders attacker-controlled input without proper escaping, allowing script execution in the backend session of a victim. This issue is fixed in REDAXO version 5.21.0.