Skip to main content
VulnerabilityPublished

CVE-2026-117538: redaxo core · Cross-site Scripting

Affects redaxo coreSource CVE Database V5

0

Not known to be exploited · CVSS 2.1 Low : upgrade to 5.21.0 when convenient.

Data as of 27 Oct 2026, 11:27 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.21.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade core and redaxo/core to 5.21.0.

Affected software

ProductAffectedFixed in
redaxocoreAffected
  • <5.21.0
Fixed in
  • 5.21.0
GitHubredaxo/corepkg:github/redaxo/coreOther threatsAffected
  • <5.21.0
Fixed in
  • 5.21.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade REDAXO core to version 5.21.0 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

REDAXO core versions before 5.21.0 have a reflected cross-site scripting (XSS) vulnerability in the backend packages API. The flaw arises because a function parameter is concatenated into an error message without proper HTML escaping. An attacker can exploit this by tricking an authenticated backend user into clicking a crafted link containing a valid CSRF token, leading to JavaScript execution that can perform same-origin actions or read DOM data. This vulnerability is fixed in version 5.21.0.

References

Community reviews

Loading reviews…