CVE-2026-117656: pow-auth assent · Authentication Bypass by Spoofing
Affects pow-auth assentSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.3.2 as a priority.
Data as of 31 Oct 2026, 00:21 UTC
Thin evidence
One scorer or none| CNA (EEF) | CVSS 4.0 | 9.3 |
|---|
- Patch
- Available – fixed in 0.3.2, 18898bde0296152165ae470078490e5798329b1b
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade assent to 0.3.2; assent to 18898bde0296152165ae470078490e5798329b1b.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pow-authassent | Affected
| Fixed in
|
| assentpow-auth/assent | Affected
| Fixed in
|
Hexassentpkg:hex/assentOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:pow-auth:assent:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 0.3.2 of pow-auth Assent is available that addresses this vulnerability. Users of the affected versions (>=0.1.25 <0.3.2) should upgrade to version 0.3.2 or later to remediate this issue. No other mitigations are indicated by the vendor advisory.
Description
CVE-2026-117656 is an authentication bypass vulnerability in the Sign in with Apple strategy of the pow-auth Assent library. The flaw allows an unauthenticated remote attacker to impersonate another user by manipulating the user parameter in the authorization callback. This parameter, controlled by the client, can override verified ID token claims, enabling attackers to replace critical identity attributes such as subject and email. The vulnerability affects versions from 0.1.25 up to but not including 0.3.2 and has been fixed in version 0.3.2.
References
- github.com/pow-auth/assent/security/advisories/GHSA-9fr5-g44g-9526 (opens in a new tab)
- cna.erlef.org/cves/CVE-2026-117656.html (opens in a new tab)
- osv.dev/vulnerability/EEF-CVE-2026-117656 (opens in a new tab)
- github.com/pow-auth/assent/commit/a2d331e8c51376d6c0b04a81aad31e0b4d4d64a3 (opens in a new tab)
- github.com/pow-auth/assent/commit/18898bde0296152165ae470078490e5798329b1b (opens in a new tab)