CVE-2026-118258: i18next-http-backend · Injection
Affects i18next-http-backendSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 3.7 Low : upgrade to 4.0.4 when convenient.
Data as of 28 Oct 2026, 18:58 UTC
- Patch
- Available – fixed in 4.0.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade i18next-http-backend to 4.0.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| i18nexti18next-http-backend | Affected
| Fixed in
|
npmi18next-http-backendpkg:npm/i18next-http-backendOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade i18next-http-backend to version 4.0.4 or later, where this vulnerability is fixed. No other mitigation is required as the issue is resolved in the official patch.
Description
A vulnerability in i18next-http-backend prior to version 4.0.4 allows injection via unencoded language and namespace values in URL templates. This can enable an attacker to manipulate query parameters in translation resource requests, potentially exposing other namespaces or tenants or altering backend behavior. The issue is fixed in version 4.0.4.