Skip to main content
VulnerabilityPublished

CVE-2026-41691: i18next-http-backend · Path Traversal

Affects i18next-http-backendSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.0.5 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade i18next-http-backend to 3.0.5.

Affected software

ProductAffectedFixed in
i18nexti18next-http-backendAffected
  • <3.0.5
Fixed in
  • 3.0.5
npmi18next-http-backendpkg:npm/i18next-http-backendOther threatsAffected
  • <3.0.5
Fixed in
  • 3.0.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 3.0.5 of i18next-http-backend is available and should be applied to remediate this vulnerability. If immediate upgrading is not possible, users should sanitize the lng and ns inputs before they reach i18next by removing characters such as '..', '/', '\', '?', '#', '%', whitespace, and control characters, and by limiting the length of these inputs. This workaround reduces the risk until the official fix can be deployed.

Description

CVE-2026-41691 is a path traversal and URL injection vulnerability in i18next-http-backend versions prior to 3.0.5. The issue arises because the library interpolates language (lng) and namespace (ns) values directly into URL templates without encoding or sanitization. This allows an attacker controlling these inputs to manipulate the request URL structure, potentially accessing restricted paths. The vulnerability has been fixed in version 3.0.5. Until upgrading, users can mitigate risk by sanitizing lng and ns inputs to remove dangerous characters and limit length.

References

Community reviews

Loading reviews…