Skip to main content
VulnerabilityPublished

CVE-2026-118514: symfony · Incorrect Authorization

Affects symfonySource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 6.3 Medium · fixed in 8.1.11 : update symfony when convenient.

Data as of 6 Nov 2026, 14:19 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Checkmarx)CVSS 4.06.3
Patch
Available – fixed in 8.1.11, 7.4.23, 6.4.50 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade symfony and symfony/http-foundation to 8.1.11, 7.4.23, 6.4.50 or 5.4.56.

Affected software

ProductAffectedFixed in
symfonysymfony/http-foundationAffected
  • >=8 <8.1.11
Fixed in
  • 8.1.11
symfonysymfony/http-foundationAffected
  • >=7 <7.4.23
Fixed in
  • 7.4.23
symfonysymfony/http-foundationAffected
  • >=6 <6.4.50
Fixed in
  • 6.4.50
symfonysymfony/http-foundationAffected
  • <5.4.56
Fixed in
  • 5.4.56
Packagistsymfony/http-foundationpkg:composer/symfony/http-foundationOther threatsAffected
  • <5.4.56
  • >=6 <6.4.50
  • >=7 <7.4.23
  • >=8 <8.1.11
Fixed in
  • 5.4.56
  • 6.4.50
  • 7.4.23
  • 8.1.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Symfony HttpFoundation versions 5.4.56, 6.4.50, 7.4.23, and 8.1.11. Users should upgrade to these versions or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-118514 is an incorrect authorization vulnerability in Symfony's HttpFoundation component affecting versions prior to 5.4.56, 6.4.50, 7.4.23, and 8.1.11. The RequestMatcher and its replacement MethodRequestMatcher compare HTTP request methods verbatim, causing security rules configured for GET requests to be bypassed by sending HEAD requests. This allows attackers to trigger controller execution and access response headers despite no response body being returned. The issue also affects firewalls configured to match only GET methods, potentially allowing HEAD requests to bypass intended protections.

References

Community reviews

Loading reviews…