Skip to main content
VulnerabilityPublished

CVE-2026-118550: Drupal AI (Artificial Intelligence) · Use of Web Browser Cache Containing Sensitive Information in Drupal AI (Artificial

Affects Drupal AI (Artificial Intelligence)Source CVE Database V5

0
Compare

Not known to be exploited : upgrade to 1.5.2 or 1.4.11 when convenient.

Data as of 30 Oct 2026, 03:45 UTC

Severity
Medium

Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 1.5.2, 1.4.11

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade AI (Artificial Intelligence) and drupal/ai to 1.5.2 or 1.4.11.

Affected software

ProductAffectedFixed in
DrupalAI (Artificial Intelligence)Affected
  • >=1.5.0 <1.5.2
Fixed in
  • 1.5.2
DrupalAI (Artificial Intelligence)Affected
  • <1.4.11
Fixed in
  • 1.4.11
Packagistdrupal/aipkg:composer/drupal/aiOther threatsAffected
  • <1.4.11
  • >=1.5.0 <1.5.2
Fixed in
  • 1.4.11
  • 1.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Drupal AI to version 1.4.11 or later, or 1.5.2 or later, where this vulnerability has been fixed. No other mitigation steps are indicated.

Description

CVE-2026-118550 is a vulnerability in Drupal AI (Artificial Intelligence) involving the use of web browser cache containing sensitive information. This issue arises from incorrectly configured access control security levels, potentially exposing sensitive data through the browser cache. It affects Drupal AI versions from 0.0.0 up to but not including 1.4.11, and from 1.5.0 up to but not including 1.5.2. Fixed versions are 1.4.11 and 1.5.2.

References

Community reviews

Loading reviews…