CVE-2026-118553: Drupal AI (Artificial Intelligence) · Cross-site Scripting
Affects Drupal AI (Artificial Intelligence)Source CVE Database V5
Not known to be exploited : upgrade to 1.5.2 or 1.4.11 soon.
Data as of 30 Oct 2026, 03:45 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 1.5.2, 1.4.11
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Drupal AI (Artificial Intelligence) to 1.5.2 or 1.4.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalAI (Artificial Intelligence) | Affected
| Fixed in
|
| DrupalAI (Artificial Intelligence) | Affected
| Fixed in
|
AI-suggested
Apply the official fixes by upgrading Drupal AI to version 1.4.11 or later, or 1.5.2 or later, as these versions contain patches addressing this stored XSS vulnerability.
Description
A stored cross-site scripting (XSS) vulnerability exists in Drupal AI (Artificial Intelligence) versions from 0.0.0 up to 1.4.11 and from 1.5.0 up to 1.5.2. This vulnerability is due to improper neutralization of input during web page generation, allowing malicious scripts to be stored and executed in users' browsers.