CVE-2026-84911: Drupal AI (Artificial Intelligence) · Cross-site Scripting
Affects Drupal AI (Artificial Intelligence)Source CVE Database V5
Not known to be exploited · CVSS 3.1 Low : upgrade to 1.4.8 or 1.3.13 when convenient.
Data as of 26 Oct 2026, 11:54 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-10-22.
- Patch
- Available – fixed in 1.4.8, 1.3.13
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Drupal AI (Artificial Intelligence) to 1.4.8 or 1.3.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalAI (Artificial Intelligence) | Affected
| Fixed in
|
| DrupalAI (Artificial Intelligence) | Affected
| Fixed in
|
AI-suggested
Upgrade affected Drupal AI installations to version 1.3.13 or later, or 1.4.8 or later, where this vulnerability has been fixed. No other mitigation is indicated by the vendor advisory.
Description
CVE-2026-84911 is a stored cross-site scripting (XSS) vulnerability in the Drupal AI (Artificial Intelligence) product. It affects versions from 0.0.0 up to but not including 1.3.13, and from 1.4.0 up to but not including 1.4.8. The vulnerability involves improper neutralization of input during web page generation, which could allow an attacker with high privileges and user interaction to inject malicious scripts. The issue has been fixed in versions 1.3.13 and 1.4.8.