CVE-2026-118546: Drupal AI (Artificial Intelligence) · Cross-site Scripting
Affects Drupal AI (Artificial Intelligence)Source CVE Database V5
Not known to be exploited : upgrade to 1.5.2 or 1.4.11 soon.
Data as of 30 Oct 2026, 03:45 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 1.5.2, 1.4.11
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Drupal AI (Artificial Intelligence) to 1.5.2 or 1.4.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalAI (Artificial Intelligence) | Affected
| Fixed in
|
| DrupalAI (Artificial Intelligence) | Affected
| Fixed in
|
AI-suggested
Upgrade Drupal AI to version 1.4.11 or later, or 1.5.2 or later, where this vulnerability has been fixed. No other mitigation actions are specified.
Description
CVE-2026-118546 is a Cross-site Scripting (XSS) vulnerability in the Drupal AI (Artificial Intelligence) product. It affects versions from 0.0.0 up to but not including 1.4.11, and from 1.5.0 up to but not including 1.5.2. The vulnerability arises from improper neutralization of input during web page generation, allowing attackers to inject malicious scripts. Fixed versions are 1.4.11 and 1.5.2.