Skip to main content
VulnerabilityPublished

CVE-2026-11860: OpenSolution Quick.CMS · Deserialization of Untrusted Data

Affects OpenSolution Quick.CMSSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 6.8 : patch OpenSolution Quick.CMS soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8
CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
OpenSolutionQuick.CMSAffected
  • <=6.8
Fixed in–

AI-suggested

A patch is available that mitigates this vulnerability by enforcing HTTPS communication, released in Quick.CMS version 6.8 on May 14, 2026. Deployments should upgrade to version 6.8 or later to remediate this issue. Until patched, avoid using the admin panel over unencrypted HTTP channels to reduce risk.

Description

Quick.CMS deserializes user-controlled data received over plaintext HTTP without ensuring integrity or authenticity. This allows attackers to tamper with serialized payloads in transit and inject malicious objects. Because deserialization is performed without proper validation or class restrictions, crafted payloads can trigger dangerous magic methods (e.g., __wakeup() and __destruct()) and leverage gadget chains, resulting in arbitrary code execution. Exploitation is triggered automatically when an administrator accesses the admin panel. When successfully exploited, this vulnerability allows attackers to execute arbitrary code on the server via manipulated serialized data transmitted over an unprotected channel. This issue was mitigated by limiting the communication to HTTPS in a patch for version 6.8 published on 14.05.2026, deployments without this patch remain vulnerable.

References

Community reviews

Loading reviews…