Skip to main content
VulnerabilityPublished

CVE-2026-118660: capricorn86 happy-dom · Server-Side Request Forgery (SSRF)

Affects capricorn86 happy-domSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 21.0.0 soon.

Data as of 28 Oct 2026, 20:43 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 21.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade capricorn86 happy-dom to 21.0.0.

Affected software

ProductAffectedFixed in
capricorn86happy-domAffected
  • <21.0.0
Fixed in
  • 21.0.0
npmhappy-dompkg:npm/happy-domOther threatsAffected
  • <21.0.0
Fixed in
  • 21.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Happy DOM to version 21.0.0 or later, where the vulnerability is fixed by changing default settings to disable iframe and CSS file loading during HTML parsing. No other mitigation is required as the fix is official and available.

Description

Happy DOM versions prior to 21.0.0 are vulnerable to a Server-Side Request Forgery (SSRF) issue. The vulnerability arises because the default settings allow loading of iframe src URLs and stylesheet href URLs while parsing untrusted HTML on the server. This behavior enables an attacker controlling the HTML input to induce the server to make arbitrary requests to internal or cloud endpoints, potentially exposing sensitive data or credentials. The issue is resolved in version 21.0.0.

References

Community reviews

Loading reviews…