Skip to main content
VulnerabilityPublished

CVE-2026-118665: ardatan graphql-tools · Insufficient Session Expiration

Affects ardatan graphql-toolsSource CVE Database V5

0

Not known to be exploited · CVSS 8.2 High : upgrade to 9.0.36 soon.

Data as of 28 Oct 2026, 21:14 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.0.36, 1.1.36
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade graphql-tools to 9.0.36; executor-legacy-ws to 1.1.36.

Affected software

ProductAffectedFixed in
ardatangraphql-toolsAffected
  • <9.0.36
Fixed in
  • 9.0.36
@graphql-toolsexecutor-legacy-wsAffected
  • <1.1.36
Fixed in
  • 1.1.36

AI-suggested

Upgrade the graphql-tools legacy WebSocket executor package to version 1.1.36 or later, where this issue is fixed. Applications that instantiate a new executor for every request are not affected. No other mitigation is indicated.

Description

CVE-2026-118665 is a high-severity vulnerability in the ardatan graphql-tools legacy WebSocket executor package prior to version 1.1.36. The issue involves insufficient session expiration where sensitive connection parameters from a previous request are retained and reused in subsequent requests with different authorization contexts. This can cause a later request to be authenticated as an earlier user if it omits certain sensitive keys. The vulnerability is fixed in version 1.1.36.

References

Community reviews

Loading reviews…