CVE-2026-118670: OHIF Viewers · Cross-site Scripting
Affects OHIF ViewersSource CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 3.14.0-beta.19 : patch OHIF Viewers soon.
Data as of 6 Nov 2026, 17:39 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 8.8 |
|---|
- Patch
- Available – fixed in 3.14.0-beta.19, 3.13.7, 3.12.15
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade Viewers and ohif/Viewers to 3.14.0-beta.19, 3.13.7 or 3.12.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OHIFViewers | Affected
| Fixed in
|
| OHIFViewers | Affected
| Fixed in
|
| OHIFViewers | Affected
| Fixed in
|
GitHubohif/Viewerspkg:github/ohif/ViewersOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OHIF Viewers to version 3.12.15, 3.13.7, or 3.14.0-beta.19 or later, where this vulnerability is fixed. No other specific mitigations are indicated by the vendor advisory.
Description
CVE-2026-118670 is a high-severity cross-site scripting (XSS) vulnerability in OHIF Viewers, a zero-footprint DICOM viewer. The flaw exists in the dicom-pdf extension versions from 3.5.0-beta.0 up to but not including 3.12.15, 3.13.7, and 3.14.0-beta.19. It allows an attacker to craft a malicious DICOM object with a manipulated MIMETypeOfEncapsulatedDocument, causing the application to treat attacker-controlled content as HTML with the OHIF origin. This enables script execution that can access session storage, authentication tokens, and same-origin PACS requests. The vulnerability is fixed in versions 3.12.15, 3.13.7, and 3.14.0-beta.19.
References
- github.com/OHIF/Viewers/security/advisories/GHSA-xwgp-w3pj-q5h3 (opens in a new tab)
- github.com/OHIF/Viewers/pull/6228 (opens in a new tab)
- github.com/OHIF/Viewers/commit/db546701bd5f2be9031c835f1de5c40aacd3dc62 (opens in a new tab)
- github.com/OHIF/Viewers/commit/ef0811c66cdb04ba07ffaba145cf66ce01486899 (opens in a new tab)
- github.com/OHIF/Viewers/commit/f0dba789a313f40fe7e8a8cbec322a8d8a491d76 (opens in a new tab)
- github.com/OHIF/Viewers/releases/tag/v3.12.15 (opens in a new tab)
- github.com/OHIF/Viewers/releases/tag/v3.13.7 (opens in a new tab)
- github.com/OHIF/Viewers/releases/tag/v3.14.0-beta.19 (opens in a new tab)