CVE-2026-118697: JetBrains Toolbox App · Improper Certificate Validation
Affects JetBrains Toolbox AppSource CVE Database V5
Not known to be exploited · CVSS 9.0 Critical : upgrade to 3.9.1 or 3.8.2 as a priority.
Data as of 30 Oct 2026, 19:03 UTC
Thin evidence
One scorer or none| CNA (JetBrains) | CVSS 3.1 | 9.0 |
|---|
- Patch
- Available – fixed in 3.9.1, 3.8.2, 2026.2.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Toolbox App to 3.9.1 or 3.8.2; IntelliJ IDEA to 2026.2.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JetBrainsToolbox App | Affected
| Fixed in
|
| JetBrainsToolbox App | Affected
| Fixed in
|
| JetBrainsIntelliJ IDEA | Affected
| Fixed in
|
AI-suggested
Users should upgrade affected JetBrains Toolbox App versions to 3.9.1 or later, versions before 3.8.2 to 3.8.2 or later, and IntelliJ IDEA to 2026.2.4 or later where the issue is fixed. No other mitigation is indicated by the vendor advisory.
Description
In JetBrains Toolbox App before 3.9.1 and 3.8.2; IntelliJ IDEA before 2026.3 and 2026.2.4, the jetbrainsd daemon trusted compromised intermediate certificates