CVE-2026-11870: WP Ghost (Hide My WP Ghost) · Authentication Bypass by Spoofing
Affects WP Ghost (Hide My WP Ghost)Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 7.0.05 when convenient.
Data as of 29 Oct 2026, 10:37 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.05
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade WP Ghost (Hide My WP Ghost) to 7.0.05.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WP Ghost (Hide My WP Ghost) | Affected
| Fixed in
|
AI-suggested
Users should upgrade to version 7.0.05 or later once available, as this version is indicated as the fixed version. Until then, consider restricting access to trusted IP ranges at the network level or disabling the affected plugin if feasible.
Description
CVE-2026-11870 is a medium severity vulnerability in the WP Ghost (Hide My WP Ghost) WordPress plugin before version 7.0.05. The plugin fails to verify that client IP information originates from a trusted proxy before trusting HTTP headers that can be controlled by an attacker. This allows unauthenticated attackers to spoof their IP address, bypassing the plugin's brute-force protection and downgrading its firewall by matching a hardcoded whitelisted IP range.