Skip to main content
VulnerabilityPublished

CVE-2026-118758: kubeflow pipelines · Path Traversal

Affects kubeflow pipelinesSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 2.18.0 soon.

Data as of 29 Oct 2026, 18:49 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 2.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade pipelines and kubeflow/pipelines to 2.18.0.

Affected software

ProductAffectedFixed in
kubeflowpipelinesAffected
  • <2.18.0
Fixed in
  • 2.18.0
GitHubkubeflow/pipelinespkg:github/kubeflow/pipelinesOther threatsAffected
  • <2.18.0
Fixed in
  • 2.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Kubeflow Pipelines to version 2.18.0 or later, where this path traversal vulnerability is fixed. Until then, ensure authentication is enabled to restrict access to authorized users only, as deployments with authentication disabled allow unauthenticated access to this flaw. No other mitigations are specified.

Description

CVE-2026-118758 is a path traversal vulnerability in Kubeflow Pipelines prior to version 2.18.0. The volume artifact handler for the GET /artifacts/get?source=volume endpoint did not properly restrict file paths to the selected volume, allowing an attacker who can access this route and identify a mounted volume to read files outside that volume. The vulnerability affects deployments with disabled authentication or where the attacker is authorized for the namespace. The issue is fixed in version 2.18.0.

References

Community reviews

Loading reviews…