CVE-2026-118760: kubeflow pipelines · Insecure Direct Object Reference
Affects kubeflow pipelinesSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.17.0 when convenient.
Data as of 29 Oct 2026, 17:07 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 6.5 |
|---|
- Patch
- Available – fixed in 2.17.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade pipelines and kubeflow/pipelines to 2.17.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| kubeflowpipelines | Affected
| Fixed in
|
GitHubkubeflow/pipelinespkg:github/kubeflow/pipelinesOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Kubeflow Pipelines to version 2.17.0 or later, where this authorization bypass vulnerability is fixed. Prior to upgrading, restrict frontend access to trusted users and networks to reduce exposure. No other mitigations are specified by the vendor.
Description
Kubeflow Pipelines versions prior to 2.17.0 contain an authorization bypass vulnerability in the frontend artifact routes. Authenticated users could access artifact contents from other tenants' namespaces without proper authorization checks, potentially exposing datasets, models, or pipeline outputs. This affects multi-user deployments relying on Kubeflow Pipelines for tenant isolation. The vulnerability does not allow disclosure of Kubernetes Secrets, modification of storage, or server-side code execution. The issue is fixed in version 2.17.0.
References
- github.com/kubeflow/pipelines/security/advisories/GHSA-vjhf-6c8f-qhwj (opens in a new tab)
- github.com/kubeflow/pipelines/issues/9889 (opens in a new tab)
- github.com/kubeflow/pipelines/pull/12860 (opens in a new tab)
- github.com/kubeflow/pipelines/commit/fb69119c997402ebddab4f6410c617cb3d3634ba (opens in a new tab)
- github.com/kubeflow/pipelines/releases/tag/2.17.0 (opens in a new tab)