Skip to main content
VulnerabilityPublished

@eeacms/volto-chatbot has Unauthenticated Danswer API Confused Deputy Proxy

Affects @eeacms/volto-chatbotSource GCVE Database

0

CVSS 8.2 High : upgrade to 2.0.4 soon.

Data as of 29 Oct 2026, 17:11 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.0.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

What to do

Upgrade @eeacms/volto-chatbot to 2.0.4.

Affected software

ProductAffectedFixed in
npm@eeacms/volto-chatbotAffected
  • <2.0.4
Fixed in
  • 2.0.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in @eeacms/volto-chatbot version 2.0.4 that fixes this vulnerability. Users should upgrade to version 2.0.4 or later to remediate the issue. Until patched, no effective mitigation is described other than disabling or restricting access to the vulnerable middleware route. The vendor advisory confirms the fix in 2.0.4.

Description

@eeacms/volto-chatbot version prior to 2.0.4 contains an unauthenticated proxy vulnerability that allows attackers to invoke arbitrary Danswer API operations with server-side credentials. The middleware route '**/_v1_da/**' accepts any HTTP method and path without authentication or path restrictions, forwarding requests with attached API keys or session cookies. This enables a Confused Deputy attack where attackers can perform privileged actions on the upstream Danswer API as the configured service account.

References

Community reviews

Loading reviews…