Skip to main content
VulnerabilityPublished

CVE-2026-118775: digitalbazaar forge · Integer Overflow or Wraparound

Affects digitalbazaar forgeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.7 Low : upgrade to 1.4.1 when convenient.

Data as of 29 Oct 2026, 19:15 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.13.7
Patch
Available – fixed in 1.4.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade digitalbazaar forge to 1.4.1.

Affected software

ProductAffectedFixed in
digitalbazaarforgeAffected
  • <1.4.1
Fixed in
  • 1.4.1
npmforgepkg:npm/forgeOther threatsAffected
  • <1.4.1
Fixed in
  • 1.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to digitalbazaar forge version 1.4.1 or later, where this vulnerability is fixed. No other mitigation is required as the issue is resolved in the official patch.

Description

CVE-2026-118775 is an integer overflow vulnerability in the digitalbazaar forge library prior to version 1.4.1. The flaw exists in the asn1.oidToDer() function, which did not properly range-check the first two arcs of an Object Identifier (OID). This could allow an application that accepts and authorizes an untrusted OID string to encode a DER representation that differs from the authorized OID. The vulnerability is fixed in version 1.4.1.

References

Community reviews

Loading reviews…