Skip to main content
VulnerabilityPublished

CVE-2026-119146: ProFTPD · Classic Buffer Overflow

Affects ProFTPDSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 1.3.10rc5 or 1.3.9e when convenient.

Data as of 30 Oct 2026, 12:04 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.3
CNA (VulnCheck)CVSS 3.15.6
Patch
Available – fixed in 1.3.10rc5, 1.3.9e
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade ProFTPD to 1.3.10rc5 or 1.3.9e.

Affected software

ProductAffectedFixed in
ProFTPD ProjectProFTPDAffected
  • >=1.3.10rc1 <1.3.10rc5
Fixed in
  • 1.3.10rc5
ProFTPD ProjectProFTPDAffected
  • <1.3.9e
Fixed in
  • 1.3.9e
GitHubProFTPDpkg:github/ProFTPDOther threatsAffected
  • <1.3.9e
  • >=1.3.10rc1 <1.3.10rc5
Fixed in
  • 1.3.9e
  • 1.3.10rc5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ProFTPD to version 1.3.9e or later, or 1.3.10rc5 or later, where this vulnerability has been fixed. No other mitigation or temporary workaround is indicated in the available data.

Description

ProFTPD versions before 1.3.9e and between 1.3.10rc1 and before 1.3.10rc5 contain a buffer overflow vulnerability in the mod_rewrite int:utf8trans RewriteMap. This flaw allows remote attackers to send FTP command arguments longer than 1024 bytes, potentially overwriting static buffers and corrupting session memory, which can lead to session crashes. The vulnerability can be exploited without authentication if pre-login commands are rewritten.

References

Community reviews

Loading reviews…