Skip to main content
VulnerabilityPublished

CVE-2026-119190: digitalbazaar forge · Improper Certificate Validation

Affects digitalbazaar forgeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.4 High : upgrade to 1.4.1 soon.

Data as of 29 Oct 2026, 20:45 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.4
Patch
Available – fixed in 1.4.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade forge and @digitalbazaar/forge to 1.4.1.

Affected software

ProductAffectedFixed in
digitalbazaarforgeAffected
  • <1.4.1
Fixed in
  • 1.4.1
npm@digitalbazaar/forgepkg:npm/@digitalbazaar/forgeOther threatsAffected
  • <1.4.1
Fixed in
  • 1.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to node-forge version 1.4.1 or later, where this improper certificate validation issue is fixed. No other mitigation is necessary as the vulnerability is resolved in the official patch.

Description

Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior to 1.4.1, node-forge parsed deprecated extension OIDs 2.5.29.10 and 2.5.29.13 as basicConstraints, and pki.verifyCertificateChain() used the first extension with that name. Exploitation requires a CA trusted by the application to issue a certificate carrying an attacker-supplied deprecated-OID extension, commonly because the CA copies extensions from a certificate signing request. By placing a permissive deprecated extension before the genuine 2.5.29.19 basicConstraints extension, the certificate holder could have the certificate accepted as a CA and issue certificates for arbitrary names, enabling server or client impersonation. If the issuing CA adds a keyUsage extension without keyCertSign, node-forge rejects the chain. This issue is fixed in version 1.4.1.

References

Community reviews

Loading reviews…