Skip to main content
VulnerabilityPublished

CVE-2026-119276: mariadb-connector-j · Improper Handling of Length Parameter Inconsistency

Affects mariadb-connector-jSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium · fixed in 3.5.11 : update mariadb-connector-j when convenient.

Data as of 29 Oct 2026, 21:15 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.15.9
Patch
Available – fixed in 3.5.11, 3.4.5, 3.3.7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mariadb-connector-j to 3.5.11, 3.4.5 or 3.3.7.

Affected software

ProductAffectedFixed in
mariadb-corporationmariadb-connector-jAffected
  • >=3.5.0 <3.5.11
Fixed in
  • 3.5.11
mariadb-corporationmariadb-connector-jAffected
  • >=3.4.0 <3.4.5
Fixed in
  • 3.4.5
mariadb-corporationmariadb-connector-jAffected
  • >=3.0.0 <3.3.7
Fixed in
  • 3.3.7

AI-suggested

Upgrade MariaDB Connector/J to version 3.3.7, 3.4.5, or 3.5.11 or later, where this issue is fixed. No other mitigation is indicated by the vendor advisory.

Description

MariaDB Connector/J versions 3.0.0 up to but not including 3.3.7, 3.4.0 up to 3.4.5, and 3.5.0 up to 3.5.11 contain a vulnerability where the client improperly handles length parameters in OK packets. This can lead to excessive heap allocations and potentially cause an OutOfMemoryError in the client application when interacting with a malicious or compromised server. The issue is fixed in versions 3.3.7, 3.4.5, and 3.5.11.

References

Community reviews

Loading reviews…