CVE-2026-119282: nrwl nx · OS Command Injection
Affects nrwl nxSource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 23.1.2 or 22.7.9 soon.
Data as of 29 Oct 2026, 21:45 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 7.3 |
|---|
- Patch
- Available – fixed in 23.1.2, 22.7.9
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade nx and maven and gradle to 23.1.2 or 22.7.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nrwlnx | Affected
| Fixed in
|
| nrwlnx | Affected
| Fixed in
|
| @nxmaven | Affected
| Fixed in
|
| @nxmaven | Affected
| Fixed in
|
| @nxgradle | Affected
| Fixed in
|
| @nxgradle | Affected
| Fixed in
|
AI-suggested
Upgrade both the nx package and the affected plugins (@nx/maven and @nx/gradle) to versions 22.7.9 or 23.1.2 or later. The fix requires matching releases of nx and the plugins because the plugin fix depends on code changes in the nx package. Workspaces not using these plugins are not exposed to this vulnerability.
Description
CVE-2026-119282 is an OS command injection vulnerability in the nrwl nx monorepo tool affecting certain versions of the @nx/maven and @nx/gradle plugins. The issue arises because these plugins launch project-graph analyzers through a shell and interpolate user-controlled options into shell commands, allowing command injection. This affects nx versions from 21.0.0 up to but not including 22.7.9, and from 23.0.0 up to but not including 23.1.2. The vulnerability is fixed in versions 22.7.9 and 23.1.2.
References
- github.com/nrwl/nx/security/advisories/GHSA-qm8w-vx34-5j9j (opens in a new tab)
- github.com/nrwl/nx/pull/36626 (opens in a new tab)
- github.com/nrwl/nx/commit/02c5d59e8dbbbe30963c0181c6a22cd8c1190a25 (opens in a new tab)
- github.com/nrwl/nx/commit/60196b7cfcffcada35b6b90e53bf1a78d049b548 (opens in a new tab)
- github.com/nrwl/nx/commit/c227f4780b054c512965c73aa480a48f9f781409 (opens in a new tab)
- github.com/nrwl/nx/releases/tag/22.7.9 (opens in a new tab)
- github.com/nrwl/nx/releases/tag/23.1.2 (opens in a new tab)