CVE-2026-56379: ImageMagick · Improper Encoding or Escaping of Output
Affects ImageMagickSource CVE Database V5
Not known to be exploited · CVSS 9.2 Critical : upgrade to 7.1.2-15 as a priority.
Data as of 29 Oct 2026, 21:45 UTC
Sources agree
| CNA (VulnCheck) | CVSS 4.0 | 9.2 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.1 |
| ADP (redhat-SADP) | CVSS 3.1 | 8.1 |
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers can reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-06-23.
- Patch
- Available – fixed in 7.1.2-15, 6.9.13-40
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade ImageMagick to 7.1.2-15; ImageMagick to 6.9.13-40.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ImageMagickImageMagick | Affected
| Fixed in
|
| ImageMagickImageMagick | Affected
| Fixed in
|
AI-suggested
A fix is available in ImageMagick versions 7.1.2-15 and 6.9.13-40. Users should upgrade to these fixed versions. Additionally, mitigation can be applied by restricting ImageMagick processing capabilities via policy.xml, disabling the SVG coder, and restricting delegates to prevent escalation to OS command execution. Enforcing mandatory access control mechanisms such as SELinux or AppArmor combined with seccomp syscall filtering to block execve is recommended. For systemd services running ImageMagick, enable NoNewPrivileges, ProtectSystem=strict, ProtectHome=true, and PrivateDevices=true to reduce risk.
Description
ImageMagick before 7.1.2-15 and 6.9.13-40 contains a command injection vulnerability in the SVG decoder that allows attackers to inject arbitrary MVG drawing commands. Attackers can craft malicious SVG files with injected Magick Vector Graphics commands that execute during rendering.
References
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-xpg8-7m6m-jf56 (opens in a new tab)
- vulncheck.com/advisories/imagemagick-command-injection-via-svg-decoder (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-56379 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2491700 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-56379.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:32961 (opens in a new tab)