Skip to main content
VulnerabilityPublished Updated

CVE-2026-86425: ImageMagick · Use After Free

Affects ImageMagickSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 7.1.2-30 when convenient.

Data as of 29 Oct 2026, 20:47 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.04.8
CNA (VulnCheck)CVSS 3.13.3
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-09-09.

Patch
Available – fixed in 7.1.2-30, 6.9.13-55
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade ImageMagick to 7.1.2-30; ImageMagick to 6.9.13-55.

Affected software

ProductAffectedFixed in
ImageMagickImageMagickAffected
  • >=7.0.0 <7.1.2-30
Fixed in
  • 7.1.2-30
ImageMagickImageMagickAffected
  • <6.9.13-55
Fixed in
  • 6.9.13-55

AI-suggested

Update ImageMagick to version 7.1.2-30 or later, or 6.9.13-55 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated.

Description

CVE-2026-86425 is a heap-use-after-free vulnerability in ImageMagick's PerlMagick Layer method affecting versions before 7.1.2-30 and 6.9.13-55. An attacker can supply a crafted list of images to trigger memory access after deallocation, causing a crash and denial of service.

References

Community reviews

Loading reviews…