Skip to main content
VulnerabilityPublished

CVE-2026-119424: opnsense core · CRLF Injection

Affects opnsense coreSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 26.7.8 when convenient.

Data as of 30 Oct 2026, 12:04 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.1
CNA (VulnCheck)CVSS 3.16.8
Patch
Available – fixed in 26.7.8
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade opnsense core to 26.7.8.

Affected software

ProductAffectedFixed in
opnsensecoreAffected
  • <26.7.8
Fixed in
  • 26.7.8
GitHubcorepkg:github/coreOther threatsAffected
  • <26.7.8
Fixed in
  • 26.7.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 26.7.8 of OPNsense core is available that addresses this vulnerability. Users should upgrade to version 26.7.8 or later to remediate this issue. No additional mitigations are specified or required once the update is applied.

Description

OPNsense core versions before 26.7.8 have a configuration line injection vulnerability that allows authenticated users with wireless-edit privileges to inject arbitrary directives by embedding CR/LF characters in WPA-related fields. This vulnerability enables attackers to append unauthorized wpa_supplicant or hostapd directives, potentially impacting the wireless configuration.

References

Community reviews

Loading reviews…