Skip to main content
VulnerabilityPublished

CVE-2026-119500: Flash & HTML5 Video (WordPress plugin) · Cross-site Scripting

Affects Flash & HTML5 Video (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.14.2 when convenient.

Data as of 7 Nov 2026, 10:21 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Patchstack)CVSS 3.16.5
Patch
Available – fixed in 2.14.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade Flash & HTML5 Video (WordPress plugin) to 2.14.2.

Affected software

ProductAffectedFixed in
Flash & HTML5 Videohtml5-video-playerAffected
  • <2.14.2
Fixed in
  • 2.14.2

AI-suggested

A fix for this vulnerability is available in bPlugins Flash & HTML5 Video html5-video-player version 2.14.2. Users and administrators should upgrade to this version to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-119500 is a stored cross-site scripting (XSS) vulnerability in bPlugins Flash & HTML5 Video html5-video-player versions prior to 2.14.2. The flaw involves improper neutralization of input during web page generation, allowing malicious scripts to be stored and executed in users' browsers. This vulnerability has a CVSS score of 6.5, indicating a medium severity level. A fix is available in version 2.14.2.

References

Community reviews

Loading reviews…