Skip to main content
VulnerabilityPublished

CVE-2026-120057: PostgreSQL psqlODBC · Classic Buffer Overflow

Affects PostgreSQL psqlODBCSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 18.00.0006 soon.

Data as of 2 Nov 2026, 20:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.17.5
Patch
Available – fixed in 18.00.0006
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade PostgreSQL psqlODBC to 18.00.0006.

Affected software

ProductAffectedFixed in
PostgreSQLpsqlODBCAffected
  • <18.00.0006
Fixed in
  • 18.00.0006
GitHubpsqlODBCpkg:github/psqlODBCOther threatsAffected
  • <18.00.0006
Fixed in
  • 18.00.0006

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 18.00.0006 of psqlODBC is available that addresses this buffer overflow vulnerability. Users should upgrade to version 18.00.0006 or later to remediate this issue. No other mitigation or temporary workaround is indicated.

Description

CVE-2026-120057 is a classic buffer overflow vulnerability in the PostgreSQL psqlODBC driver. The flaw occurs because psqlODBC copies data from a large-object read into the application's buffer using the length provided by the server without verifying that the buffer is large enough. This can allow a malicious or untrusted server, or a man-in-the-middle attacker, to overwrite adjacent memory in the client process. The vulnerability affects all psqlODBC versions before 18.00.0006 and can be triggered by fetching any large-object column.

References

Community reviews

Loading reviews…