CVE-2026-120205: Thelia · Cross-site Scripting
Affects TheliaSource CVE Database V5
Not known to be exploited · CVSS 7.4 High : upgrade to 3.1.0 soon.
Data as of 31 Oct 2026, 17:51 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.4 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.0 |
- Patch
- Available – fixed in 3.1.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Thelia and Thelia Core to 3.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| TheliaThelia | Affected
| Fixed in
|
| TheliaThelia Core | Affected
| Fixed in
|
PackagistTheliapkg:composer/TheliaOther threats | Affected
| Fixed in
|
PackagistThelia Corepkg:composer/Thelia CoreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Thelia to version 3.1.0 or later, where this vulnerability has been fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.
Description
Thelia versions prior to 3.1.0 contain a stored cross-site scripting (XSS) vulnerability in the ForSomeCustomers::getSummary() function. This flaw allows unauthenticated attackers to inject malicious scripts via unescaped customer names. When administrators view coupons related to these customers, the injected scripts execute, potentially stealing CSRF tokens and enabling attackers to create administrator accounts.
References
- github.com/thelia/thelia/security/advisories/GHSA-r63g-6wfg-v5v9 (opens in a new tab)
- github.com/thelia/thelia/commit/c90d59375089a0833a56703c6f9f9ddea17bddc9 (opens in a new tab)
- github.com/thelia/thelia/releases/tag/3.1.0 (opens in a new tab)
- github.com/thelia/thelia/blob/3.0.0/core/lib/Thelia/Condition/Implementation/ForSomeCustomers.php (opens in a new tab)
- vulncheck.com/advisories/thelia-before-3.1.0-stored-xss-via-coupon-condition-customer-name (opens in a new tab)