Skip to main content
VulnerabilityPublished

CVE-2026-120206: Thelia · Cross-Site Request Forgery (CSRF)

Affects TheliaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 3.2.0 when convenient.

Data as of 31 Oct 2026, 17:51 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.9
CNA (VulnCheck)CVSS 3.15.9
Patch
Available – fixed in 3.2.0, 1.2.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Thelia and Thelia Core to 3.2.0; Thelia Back-office Default Twig Template to 1.2.0.

Affected software

ProductAffectedFixed in
TheliaTheliaAffected
  • <3.2.0
Fixed in
  • 3.2.0
TheliaThelia CoreAffected
  • <3.2.0
Fixed in
  • 3.2.0
TheliaThelia Back-office Default Twig TemplateAffected
  • <1.2.0
Fixed in
  • 1.2.0
TheliaThelia Back-office Default TemplateAffected
  • <=2.6.2
Fixed in–
TheliaThelia Smarty ModuleAffected
  • <=3.0.3
Fixed in–
PackagistTheliapkg:composer/TheliaOther threatsAffected
  • <3.2.0
Fixed in
  • 3.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Thelia to version 3.2.0 or later, or 1.2.0 or later, where this vulnerability is fixed. Applying these official fixes will prevent CSRF token leakage and protect administrative actions from forgery.

Description

Thelia versions prior to 3.2.0 contain a cross-site request forgery (CSRF) vulnerability in the back office. This vulnerability arises because per-session CSRF tokens leak via URL query strings, allowing attackers to reuse these tokens or exploit unprotected actions. Specifically, attackers can target the setToggleVisibilityAction and updatePositionAction to perform unauthorized administrative actions such as deleting, hiding, or reordering catalogue and configuration objects. The issue is fixed in Thelia versions 3.2.0 and 1.2.0.

References

Community reviews

Loading reviews…