CVE-2026-120309: nuxt · Interpretation Conflict
Affects nuxtSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 4.6.2 when convenient.
Data as of 2 Nov 2026, 03:14 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.7 |
- Patch
- Available – fixed in 4.6.2
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade nuxt to 4.6.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nuxtnuxt | Affected
| Fixed in
|
npmnuxtpkg:npm/nuxtOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Nuxt to version 4.6.2 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.
Description
Nuxt versions 4.6.0 through 4.6.1 contain a route parameter confusion vulnerability in the getRouterParam and getRouterParams functions. This flaw allows attackers to craft requests with encoded question marks (%3F) in paths, causing a mismatch between parameter values used for authorization checks and those used for resource selection. This discrepancy can lead to unauthorized access to resources. The issue is fixed in version 4.6.2.