CVE-2026-120317: http4k · Insufficient Verification of Data Authenticity
Affects http4kSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 6.60.0.0 soon.
Data as of 2 Nov 2026, 02:46 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.2 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.9 |
- Patch
- Available – fixed in 6.60.0.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade http4k to 6.60.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| http4khttp4k | Affected
| Fixed in
|
Mavenhttp4kpkg:maven/http4kOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade http4k to version 6.60.0.0 or later, where the vulnerability is fixed. Until upgrading, ensure that all communications use TLS to prevent on-path attackers from intercepting and modifying requests.
Description
http4k versions from 4.9.10.0 up to but not including 6.60.0.0 have a vulnerability where the DigestEncoder fails to hash the request entity body when computing the auth-int digest. This allows on-path attackers on non-TLS channels to modify the body of authenticated requests without invalidating the Authorization header, potentially causing state-changing actions to be executed as the victim.