Skip to main content
VulnerabilityPublished

CVE-2026-120320: jxxghp MoviePilot · Deserialization

Affects jxxghp MoviePilotSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.1 Medium.

Data as of 2 Nov 2026, 01:58 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.1
CNA (VulDB)CVSS 3.14.7
CNA (VulDB)CVSS 3.04.7
CNA (VulDB)CVSS 2.05.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
jxxghpMoviePilotAffected
  • =3.1.0
  • =3.1.1
  • =3.1.2
Fixed in–
GitHubjxxghp/MoviePilotpkg:github/jxxghp/MoviePilotOther threatsAffected
  • =3.1.0
  • =3.1.1
  • =3.1.2
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:jxxghp:moviepilot:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the jxxghp MoviePilot component to version 3.1.3 or later, which contains the official fix for this deserialization vulnerability. No other mitigation is indicated or required according to the available data.

Description

CVE-2026-120320 is a deserialization vulnerability in jxxghp MoviePilot versions 3.1.0, 3.1.1, and 3.1.2. It affects the WorkflowExecutor.restore_context function in the Workflow Fork Endpoint component. The vulnerability allows remote attackers to manipulate deserialization processes. A public exploit has been disclosed. Upgrading to version 3.1.3 resolves the issue.

References

Community reviews

Loading reviews…