CVE-2026-120415: undici · Information Exposure
Affects undiciSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 5.9 Medium : upgrade to 8.12.4 or 7.30.2 when convenient.
Data as of 6 Nov 2026, 10:19 UTC
Thin evidence
One scorer or none| CNA (openjs) | CVSS 3.1 | 5.9 |
|---|
- Patch
- Available – fixed in 8.12.4, 7.30.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade undici to 8.12.4 or 7.30.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| undiciundici | Affected
| Fixed in
|
| undiciundici | Affected
| Fixed in
|
npmundicipkg:npm/undiciOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade undici to version 7.30.2 or later, or 8.12.4 or later, where this issue is fixed. As a workaround, supply request headers as a plain object or a flat name and value array instead of an array of tuples, or compose the redirect interceptor outside the normalizing interceptor. No other mitigation is indicated.
Description
A vulnerability in the undici HTTP client for Node.js allows sensitive headers such as Authorization and Cookie to be exposed to unauthorized actors during cross-origin redirects when headers are supplied as an array of tuples. This bypasses intended header stripping and can disclose origin-bound credentials. The issue affects versions 7.0.0 through 7.30.1 and 8.0.0 through 8.12.3 and is fixed in versions 7.30.2 and 8.12.4.