Skip to main content
VulnerabilityPublished

CVE-2026-120421: Eclipse Mojarra · Cross-site Scripting

Affects Eclipse MojarraSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium · fixed in 5.0.0-M12 : update Eclipse Mojarra when convenient.

Data as of 4 Nov 2026, 15:31 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (eclipse)CVSS 3.16.1
Patch
Available – fixed in 5.0.0-M12, 4.1.20, 4.0.29
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade Eclipse Mojarra to 5.0.0-M12, 4.1.20 or 4.0.29.

Affected software

ProductAffectedFixed in
Eclipse FoundationEclipse MojarraAffected
  • >=5.0.0-M1 <5.0.0-M12
Fixed in
  • 5.0.0-M12
Eclipse FoundationEclipse MojarraAffected
  • >=4.1.0 <4.1.20
Fixed in
  • 4.1.20
Eclipse FoundationEclipse MojarraAffected
  • >=2.2.0 <4.0.29
Fixed in
  • 4.0.29
Mavenorg.eclipse/mojarrapkg:maven/org.eclipse/mojarraOther threatsAffected
  • >=2.2.0 <=4.0.28
  • >=4.1.0 <=4.1.19
  • >=5.0.0-M1 <=5.0.0-M11
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions 4.0.29, 4.1.20, and 5.0.0-M12 of Eclipse Mojarra are available and should be applied to remediate this vulnerability. Users should upgrade to these versions to eliminate the risk. No vendor advisory indicates alternative mitigations or that no action is required.

Description

CVE-2026-120421 is a reflected cross-site scripting (XSS) vulnerability in Eclipse Mojarra affecting versions 2.2.0 through 4.0.28, 4.1.0 through 4.1.19, and 5.0.0-M1 through 5.0.0-M11. When URL client window mode is enabled, the client window id parameter is appended to URLs without proper URL encoding. This leads to XSS via the h:button component rendering the URL into a JavaScript string literal. The vulnerability can bypass Content Security Policy if CSP nonce is enabled. Fixed versions are available.

References

Community reviews

Loading reviews…